summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMalfurious <m@lfurio.us>2023-07-08 11:27:56 -0400
committerMalfurious <m@lfurio.us>2023-07-08 11:27:56 -0400
commit1b5f8d2e5a118a80a4373a7be1ca4e4eceebf7be (patch)
tree62ee155841728954887285e97f04d069ecdf39a4 /CMakeLists.txt
parentc29bf2efbdc4f4186f3fe571601b4d1acac4b321 (diff)
downloadmisplays-1b5f8d2e5a118a80a4373a7be1ca4e4eceebf7be.tar.gz
misplays-1b5f8d2e5a118a80a4373a7be1ca4e4eceebf7be.zip
Initial debugger core and test UI
This is vaguely competent at tracing single-threaded programs. Vi-like keybinds defined in misplays.c. Signed-off-by: Malfurious <m@lfurio.us>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b8644a7..a7ff378 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,12 +15,14 @@ add_compile_definitions(
add_executable(${PROJECT_NAME}
console.c
+ debugger.c
helpers.c
list.c
misplays.c
)
target_link_libraries(${PROJECT_NAME}
+ capstone
ncurses
panel
)