summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMalfurious <m@lfurio.us>2023-07-07 20:08:13 -0400
committerMalfurious <m@lfurio.us>2023-07-08 11:05:07 -0400
commitc29bf2efbdc4f4186f3fe571601b4d1acac4b321 (patch)
treef5a23bda3a58794679ec4ed6eb1ba7a95249954e /CMakeLists.txt
parent415c553d96c4851350512cc943e10ec477427e02 (diff)
downloadmisplays-c29bf2efbdc4f4186f3fe571601b4d1acac4b321.tar.gz
misplays-c29bf2efbdc4f4186f3fe571601b4d1acac4b321.zip
Implement trivial linked list
* Bring-your-own-node (generic / zero allocations) * Doubly-linked and circular, forward and backward traversable * Random insert/removal in constant time * All operations are no-fail * [Some type safety concessions though] Signed-off-by: Malfurious <m@lfurio.us>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7a13a74..b8644a7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,6 +16,7 @@ add_compile_definitions(
add_executable(${PROJECT_NAME}
console.c
helpers.c
+ list.c
misplays.c
)