summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4f59811..e0fd0a8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,10 @@
cmake_minimum_required(VERSION 3.0)
-project(compass CXX)
+project(compass LANGUAGES CXX)
+
+set(ENABLE_PROGRAMS OFF CACHE BOOL "Build mbedtls exemplary programs")
+set(ENABLE_TESTING OFF CACHE BOOL "Build mbedtls testing harness")
+add_subdirectory(mbedtls)
+include_directories(mbedtls/include)
add_executable(compass
main.cpp
@@ -11,4 +16,6 @@ add_executable(compass
Socket.cpp
)
+target_link_libraries(compass mbedtls)
+
install(TARGETS compass)