summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMalfurious <m@lfurio.us>2024-10-21 13:27:32 -0400
committerMalfurious <m@lfurio.us>2024-10-24 06:41:41 -0400
commitd1aea038b08db11d5f12132b2842aba5fff8dd5a (patch)
treeec570a2bfb22e645d7e911a40b7acd249f955da6 /CMakeLists.txt
parent5494fc310acf0aabb9d828451331e44483eb21c7 (diff)
downloadcompass-d1aea038b08db11d5f12132b2842aba5fff8dd5a.tar.gz
compass-d1aea038b08db11d5f12132b2842aba5fff8dd5a.zip
Add Mbedtls library
I'm planning to start rewriting compass in C, so I've been looking for a portable C-oriented crypto library to replace Crypto++. This commit adds version 3.6.0 of mbedtls to the build. Mbedtls is available under the Apache license. Signed-off-by: Malfurious <m@lfurio.us>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4f59811..e0fd0a8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,10 @@
cmake_minimum_required(VERSION 3.0)
-project(compass CXX)
+project(compass LANGUAGES CXX)
+
+set(ENABLE_PROGRAMS OFF CACHE BOOL "Build mbedtls exemplary programs")
+set(ENABLE_TESTING OFF CACHE BOOL "Build mbedtls testing harness")
+add_subdirectory(mbedtls)
+include_directories(mbedtls/include)
add_executable(compass
main.cpp
@@ -11,4 +16,6 @@ add_executable(compass
Socket.cpp
)
+target_link_libraries(compass mbedtls)
+
install(TARGETS compass)