summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml11
1 files changed, 10 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 385c6ce..d4aa8b3 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,5 @@
[project]
name = "sploit"
-version = "0.1"
description = "sploit is a process interaction automation tool with software exploitation focused utilities."
readme = "README.txt"
requires-python = ">=3.8"
@@ -10,6 +9,7 @@ authors = [
{name="dusoleil",email="howcansocksbereal@gmail.com"},
{name="Malfurious",email="m@lfurio.us"},
]
+dynamic = ["version"]
[project.urls]
"Homepage" = "https://github.com/dusoleil/sploit"
@@ -20,3 +20,12 @@ sploit = "sploit.main:main"
[build-system]
requires = ["hatchling"]
build-backend = "hatchling.build"
+
+[tool.hatch.version]
+source = "code"
+path = "sploit/__init__.py"
+search-paths = ["."]
+expression = "__version__"
+
+[tool.hatch.build.hooks.custom]
+path = "hooks/bake_version.py"