summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authordusoleil <howcansocksbereal@gmail.com>2023-02-23 05:24:29 -0500
committerdusoleil <howcansocksbereal@gmail.com>2023-02-23 22:52:57 -0500
commitb016d2b55c16d1d7303cd93d5a9a3e2362a9fb58 (patch)
treeb770cea21ded7603de0f85f466222d2ebaeb807f /setup.py
parenteb8e5caaca1349bc10a61b1fa58f3d9b31df7e13 (diff)
downloadsploit-b016d2b55c16d1d7303cd93d5a9a3e2362a9fb58.tar.gz
sploit-b016d2b55c16d1d7303cd93d5a9a3e2362a9fb58.zip
Update project's build and package to the newer standard
Currently, the standard way to build and package a Python project is through a pyproject.toml file rather than the old setup.py. This is also build back-end agnostic and we can choose to use something other than setuptools. After looking through a few options, I've decided to use hatchling. Signed-off-by: dusoleil <howcansocksbereal@gmail.com> Reviewed-by: Malfurious <m@lfurio.us>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 0 insertions, 7 deletions
diff --git a/setup.py b/setup.py
deleted file mode 100644
index 046c523..0000000
--- a/setup.py
+++ /dev/null
@@ -1,7 +0,0 @@
-from setuptools import setup, find_packages
-setup(
- name='sploit',
- version='0.1',
- packages=find_packages(),
- entry_points={"console_scripts":["sploit=sploit.main:main"]}
- )