diff options
author | Malfurious <m@lfurio.us> | 2022-03-14 00:43:15 -0400 |
---|---|---|
committer | Malfurious <m@lfurio.us> | 2022-03-14 00:43:15 -0400 |
commit | 616c8b8eadbde6fbb2fe16a6a2167e04f9d16382 (patch) | |
tree | 6560d8b5fea2b40d041f52683cd7accc61ce67a5 /setup.py | |
parent | dcba5f2b3d13f5142e4e552bdd717286f953bf1a (diff) | |
parent | c493a8f8073702bcdccdbc40bf09931e201c9013 (diff) | |
download | sploit-616c8b8eadbde6fbb2fe16a6a2167e04f9d16382.tar.gz sploit-616c8b8eadbde6fbb2fe16a6a2167e04f9d16382.zip |
Merge tag 'pull-sploit-rev' of https://github.com/Dusoleil/lib-des-gnux
Add rev for basic reverse engineering
* tag 'pull-sploit-rev' of https://github.com/Dusoleil/lib-des-gnux:
sploit: Move __attr_filter__ to a general place in util
sploit: Filter all magic python members by default in mem module
sploit: add stack base pointer to locals symtbl
sploit: print hex of addresses in rev logs
sploit: add status logging to rev module
sploit: lazy load libs for ELF
sploit: cache results of external commands
sploit: add the rest of r2 functions through elf
sploit: typo fix in rev.r2
sploit: cache ELF loads
sploit: add ELF helper class to rev
sploit: consolidate r2 symbol search calls
sploit: fix r2 module syntax error
sploit: reverse direction of r2 get_locals offsets
sploit: add r2 funcionality to rev module
sploit: add ldd ability to rev module
sploit: add rev module to sploit
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -1,7 +1,7 @@ -from setuptools import setup +from setuptools import setup, find_packages setup( name='sploit', version='0', - packages=['sploit'], + packages=find_packages(), entry_points={"console_scripts":["sploit=sploit.main:main"]} ) |