summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authordusoleil <howcansocksbereal@gmail.com>2023-02-23 05:24:29 -0500
committerdusoleil <howcansocksbereal@gmail.com>2023-02-23 22:52:57 -0500
commitb016d2b55c16d1d7303cd93d5a9a3e2362a9fb58 (patch)
treeb770cea21ded7603de0f85f466222d2ebaeb807f /pyproject.toml
parenteb8e5caaca1349bc10a61b1fa58f3d9b31df7e13 (diff)
downloadsploit-b016d2b55c16d1d7303cd93d5a9a3e2362a9fb58.tar.gz
sploit-b016d2b55c16d1d7303cd93d5a9a3e2362a9fb58.zip
Update project's build and package to the newer standard
Currently, the standard way to build and package a Python project is through a pyproject.toml file rather than the old setup.py. This is also build back-end agnostic and we can choose to use something other than setuptools. After looking through a few options, I've decided to use hatchling. Signed-off-by: dusoleil <howcansocksbereal@gmail.com> Reviewed-by: Malfurious <m@lfurio.us>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..385c6ce
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,22 @@
+[project]
+name = "sploit"
+version = "0.1"
+description = "sploit is a process interaction automation tool with software exploitation focused utilities."
+readme = "README.txt"
+requires-python = ">=3.8"
+license = "Unlicense"
+license-files.paths = ["UNLICENSE"]
+authors = [
+ {name="dusoleil",email="howcansocksbereal@gmail.com"},
+ {name="Malfurious",email="m@lfurio.us"},
+]
+
+[project.urls]
+"Homepage" = "https://github.com/dusoleil/sploit"
+
+[project.scripts]
+sploit = "sploit.main:main"
+
+[build-system]
+requires = ["hatchling"]
+build-backend = "hatchling.build"