summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMalfurious <m@lfurio.us>2024-01-13 09:26:09 -0500
committerMalfurious <m@lfurio.us>2024-05-19 17:52:10 -0400
commit8b80091fd1af821e0937eae2c208b0117ad0a996 (patch)
tree5ecfdef17b3a1a89c65075ac92e2d6038ac486a9 /pyproject.toml
parentca58214730f0f480d15be9552a9455f73e26a907 (diff)
downloadsploit-8b80091fd1af821e0937eae2c208b0117ad0a996.tar.gz
sploit-8b80091fd1af821e0937eae2c208b0117ad0a996.zip
Remove extra "main.py" file
The CLI logic is moved to sploit/__main__.py. This file is now the target of: - python -m sploit - sploit.py (via import) - sploit (installed executable - via pyproject.toml) A module guard (`if __name__ == "__main__"`) is added to allow the application to run when this file is invoked directly. And the entrypoint symlink is no longer necessary. Signed-off-by: Malfurious <m@lfurio.us>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 041ee3f..5ac11e8 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -15,7 +15,7 @@ dynamic = ["version"]
"Homepage" = "https://github.com/dusoleil/sploit"
[project.scripts]
-sploit = "sploit.main:main"
+sploit = "sploit.__main__:main"
[build-system]
requires = ["hatchling"]