summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMalfurious <m@lfurio.us>2025-01-03 09:59:53 -0500
committerMalfurious <m@lfurio.us>2025-01-04 23:54:51 -0500
commitd4aacb45a070f05eddb5fbfec191b440e381e268 (patch)
tree3b06b2f7e8c1efbace542beb4f8665dd196cc292 /pyproject.toml
parent6d1418c28161c51c6a0649207c51e9b03c7d197a (diff)
downloadnsploit-d4aacb45a070f05eddb5fbfec191b440e381e268.tar.gz
nsploit-d4aacb45a070f05eddb5fbfec191b440e381e268.zip
Don't rely on git for version information
The version information for the nsploit distribution is now defined in pyproject.toml, and we no longer attempt to obtain details via git-describe. As previously, the library version is made available via `nsploit.__version__`. The main benefit of working this way is to allow a proper install of nsploit from a simple tarball of the source code, or even a shallow git clone. In each of these cases, tag information will not usually be present. As an added feature over the previous system, nsploit will now report in its version string if the running version is from a source tree, rather than an installed copy. Signed-off-by: Malfurious <m@lfurio.us>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml11
1 files changed, 1 insertions, 10 deletions
diff --git a/pyproject.toml b/pyproject.toml
index b2f5a49..63c07ed 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -9,7 +9,7 @@ authors = [
{name="dusoleil",email="howcansocksbereal@gmail.com"},
{name="Malfurious",email="m@lfurio.us"},
]
-dynamic = ["version"]
+version = "0.4.0"
[project.urls]
"Homepage" = "https://github.com/dusoleil/sploit"
@@ -20,12 +20,3 @@ nsploit = "nsploit.__main__:main"
[build-system]
requires = ["hatchling"]
build-backend = "hatchling.build"
-
-[tool.hatch.version]
-source = "code"
-path = "nsploit/__init__.py"
-search-paths = ["."]
-expression = "__version__"
-
-[tool.hatch.build.hooks.custom]
-path = "hooks/bake_version.py"