summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMalfurious <m@lfurio.us>2024-01-13 09:26:09 -0500
committerMalfurious <m@lfurio.us>2024-01-13 17:22:12 -0500
commitd051f6d7daa4e0c025dcb58af392cca47c6019d7 (patch)
treec10e90326ee2772ced8e9ee7d74d8c9f870cd1d9 /pyproject.toml
parent03e1f242f69903fcd132010228259231301b3f43 (diff)
downloadnsploit-d051f6d7daa4e0c025dcb58af392cca47c6019d7.tar.gz
nsploit-d051f6d7daa4e0c025dcb58af392cca47c6019d7.zip
Remove extra "main.py" file
The CLI logic is moved to sploit/__main__.py. This file is now the target of: - python -m sploit - sploit.py (via import) - sploit (installed executable - via pyproject.toml) A module guard (`if __name__ == "__main__"`) is added to allow the application to run when this file is invoked directly. And the entrypoint symlink is no longer necessary. Signed-off-by: Malfurious <m@lfurio.us>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 041ee3f..5ac11e8 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -15,7 +15,7 @@ dynamic = ["version"]
"Homepage" = "https://github.com/dusoleil/sploit"
[project.scripts]
-sploit = "sploit.main:main"
+sploit = "sploit.__main__:main"
[build-system]
requires = ["hatchling"]