summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMalfurious <m@lfurio.us>2023-07-05 16:11:16 -0400
committerMalfurious <m@lfurio.us>2023-07-05 16:11:16 -0400
commit4def3856f105b1461615285c9e33750a51177994 (patch)
treef1bc62f0321d92f64f06a9621b3c81803cc281e7 /CMakeLists.txt
parentfae455643c4f9d22bff18df949ac773e10e97dee (diff)
downloadmisplays-4def3856f105b1461615285c9e33750a51177994.tar.gz
misplays-4def3856f105b1461615285c9e33750a51177994.zip
Add CMake build system
Signed-off-by: Malfurious <m@lfurio.us>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..29662a6
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,27 @@
+cmake_minimum_required(VERSION 3.12)
+
+project(
+ misplays
+ VERSION 0.0.1
+ LANGUAGES C
+)
+
+set_property(GLOBAL PROPERTY C_STANDARD 99)
+add_compile_options(-W -Wall -Wextra -Wpedantic -g)
+add_compile_definitions(
+ MISPLAYS_VERSION=${PROJECT_VERSION}
+ _GNU_SOURCE
+)
+
+add_executable(${PROJECT_NAME}
+ console.c
+ curshelpers.c
+ misplays.c
+)
+
+target_link_libraries(${PROJECT_NAME}
+ ncurses
+ panel
+)
+
+install(TARGETS ${PROJECT_NAME})