summaryrefslogtreecommitdiffstats
path: root/tools/sploit/setup.py
diff options
context:
space:
mode:
authorMalfurious <m@lfurio.us>2022-03-14 00:43:15 -0400
committerMalfurious <m@lfurio.us>2022-03-14 00:43:15 -0400
commit380bc782b53bdafc2b1d5d37afb16d6d7b91a0e5 (patch)
tree6fb4228ddfc96d9591240e6a654e0fe199bb12fc /tools/sploit/setup.py
parent6e24dc3d70b9e915c89d47dc8d7c816f1ba8ffab (diff)
parentcd12c17a6a41102f55ef034fb819a2ee093df356 (diff)
downloadlib-des-gnux-380bc782b53bdafc2b1d5d37afb16d6d7b91a0e5.tar.gz
lib-des-gnux-380bc782b53bdafc2b1d5d37afb16d6d7b91a0e5.zip
Merge tag 'pull-sploit-rev' of https://github.com/Dusoleil/lib-des-gnux
Add rev for basic reverse engineering * tag 'pull-sploit-rev' of https://github.com/Dusoleil/lib-des-gnux: sploit: Move __attr_filter__ to a general place in util sploit: Filter all magic python members by default in mem module sploit: add stack base pointer to locals symtbl sploit: print hex of addresses in rev logs sploit: add status logging to rev module sploit: lazy load libs for ELF sploit: cache results of external commands sploit: add the rest of r2 functions through elf sploit: typo fix in rev.r2 sploit: cache ELF loads sploit: add ELF helper class to rev sploit: consolidate r2 symbol search calls sploit: fix r2 module syntax error sploit: reverse direction of r2 get_locals offsets sploit: add r2 funcionality to rev module sploit: add ldd ability to rev module sploit: add rev module to sploit
Diffstat (limited to 'tools/sploit/setup.py')
-rw-r--r--tools/sploit/setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/sploit/setup.py b/tools/sploit/setup.py
index eb1b299..5afa958 100644
--- a/tools/sploit/setup.py
+++ b/tools/sploit/setup.py
@@ -1,7 +1,7 @@
-from setuptools import setup
+from setuptools import setup, find_packages
setup(
name='sploit',
version='0',
- packages=['sploit'],
+ packages=find_packages(),
entry_points={"console_scripts":["sploit=sploit.main:main"]}
)