summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt145
1 files changed, 8 insertions, 137 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ffea003..e0fd0a8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,10 @@
cmake_minimum_required(VERSION 3.0)
-project(compass CXX)
+project(compass LANGUAGES CXX)
+
+set(ENABLE_PROGRAMS OFF CACHE BOOL "Build mbedtls exemplary programs")
+set(ENABLE_TESTING OFF CACHE BOOL "Build mbedtls testing harness")
+add_subdirectory(mbedtls)
+include_directories(mbedtls/include)
add_executable(compass
main.cpp
@@ -9,142 +14,8 @@ add_executable(compass
Keychain.cpp
Options.cpp
Socket.cpp
- cryptopp562/3way.cpp
- cryptopp562/adler32.cpp
- cryptopp562/algebra.cpp
- cryptopp562/algparam.cpp
- cryptopp562/arc4.cpp
- cryptopp562/asn.cpp
- cryptopp562/authenc.cpp
- cryptopp562/base32.cpp
- cryptopp562/base64.cpp
- cryptopp562/basecode.cpp
- cryptopp562/bench2.cpp
- cryptopp562/bench.cpp
- cryptopp562/bfinit.cpp
- cryptopp562/blowfish.cpp
- cryptopp562/blumshub.cpp
- cryptopp562/camellia.cpp
- cryptopp562/cast.cpp
- cryptopp562/casts.cpp
- cryptopp562/cbcmac.cpp
- cryptopp562/ccm.cpp
- cryptopp562/channels.cpp
- cryptopp562/cmac.cpp
- cryptopp562/cpu.cpp
- cryptopp562/crc.cpp
- cryptopp562/cryptlib_bds.cpp
- cryptopp562/cryptlib.cpp
- cryptopp562/datatest.cpp
- cryptopp562/default.cpp
- cryptopp562/des.cpp
- cryptopp562/dessp.cpp
- cryptopp562/dh2.cpp
- cryptopp562/dh.cpp
- cryptopp562/dll.cpp
- cryptopp562/dlltest.cpp
- cryptopp562/dsa.cpp
- cryptopp562/eax.cpp
- cryptopp562/ec2n.cpp
- cryptopp562/eccrypto.cpp
- cryptopp562/ecp.cpp
- cryptopp562/elgamal.cpp
- cryptopp562/emsa2.cpp
- cryptopp562/eprecomp.cpp
- cryptopp562/esign.cpp
- cryptopp562/files.cpp
- cryptopp562/filters.cpp
- cryptopp562/fips140.cpp
- cryptopp562/fipsalgt.cpp
- cryptopp562/fipstest.cpp
- cryptopp562/gcm.cpp
- cryptopp562/gf2_32.cpp
- cryptopp562/gf256.cpp
- cryptopp562/gf2n.cpp
- cryptopp562/gfpcrypt.cpp
- cryptopp562/gost.cpp
- cryptopp562/gzip.cpp
- cryptopp562/hex.cpp
- cryptopp562/hmac.cpp
- cryptopp562/hrtimer.cpp
- cryptopp562/ida.cpp
- cryptopp562/idea.cpp
- cryptopp562/integer.cpp
- cryptopp562/iterhash.cpp
- cryptopp562/luc.cpp
- cryptopp562/mars.cpp
- cryptopp562/marss.cpp
- cryptopp562/md2.cpp
- cryptopp562/md4.cpp
- cryptopp562/md5.cpp
- cryptopp562/misc.cpp
- cryptopp562/modes.cpp
- cryptopp562/mqueue.cpp
- cryptopp562/mqv.cpp
- cryptopp562/nbtheory.cpp
- cryptopp562/network.cpp
- cryptopp562/oaep.cpp
- cryptopp562/osrng.cpp
- cryptopp562/panama.cpp
- cryptopp562/pch.cpp
- cryptopp562/pkcspad.cpp
- cryptopp562/polynomi.cpp
- cryptopp562/pssr.cpp
- cryptopp562/pubkey.cpp
- cryptopp562/queue.cpp
- cryptopp562/rabin.cpp
- cryptopp562/randpool.cpp
- cryptopp562/rc2.cpp
- cryptopp562/rc5.cpp
- cryptopp562/rc6.cpp
- cryptopp562/rdtables.cpp
- cryptopp562/regtest.cpp
- cryptopp562/rijndael.cpp
- cryptopp562/ripemd.cpp
- cryptopp562/rng.cpp
- cryptopp562/rsa.cpp
- cryptopp562/rw.cpp
- cryptopp562/safer.cpp
- cryptopp562/salsa.cpp
- cryptopp562/seal.cpp
- cryptopp562/seed.cpp
- cryptopp562/serpent.cpp
- cryptopp562/sha3.cpp
- cryptopp562/shacal2.cpp
- cryptopp562/sha.cpp
- cryptopp562/sharkbox.cpp
- cryptopp562/shark.cpp
- cryptopp562/simple.cpp
- cryptopp562/skipjack.cpp
- cryptopp562/socketft.cpp
- cryptopp562/sosemanuk.cpp
- cryptopp562/square.cpp
- cryptopp562/squaretb.cpp
- cryptopp562/strciphr.cpp
- cryptopp562/tea.cpp
- cryptopp562/test.cpp
- cryptopp562/tftables.cpp
- cryptopp562/tiger.cpp
- cryptopp562/tigertab.cpp
- cryptopp562/trdlocal.cpp
- cryptopp562/ttmac.cpp
- cryptopp562/twofish.cpp
- cryptopp562/validat1.cpp
- cryptopp562/validat2.cpp
- cryptopp562/validat3.cpp
- cryptopp562/vmac.cpp
- cryptopp562/wait.cpp
- cryptopp562/wake.cpp
- cryptopp562/whrlpool.cpp
- cryptopp562/winpipes.cpp
- cryptopp562/xtr.cpp
- cryptopp562/xtrcrypt.cpp
- cryptopp562/zdeflate.cpp
- cryptopp562/zinflate.cpp
- cryptopp562/zlib.cpp
)
-# TODO - Windows needs winsock
-find_library(PTHREAD_LIB pthread)
-target_link_libraries(compass ${PTHREAD_LIB})
+target_link_libraries(compass mbedtls)
+
install(TARGETS compass)