summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMalfurious <m@lfurio.us>2021-08-28 09:45:57 -0400
committerMalfurious <m@lfurio.us>2021-08-28 10:01:42 -0400
commit7bd18b4b22f3a6bf86b131329345f9a75d8f699c (patch)
tree07f2ac0cb38a7424b711c2dd9b59116e2ed0848b /Cargo.toml
parent1522a21d24add0d78f7e4a5fae7654b709045754 (diff)
downloadSorensenCompression-7bd18b4b22f3a6bf86b131329345f9a75d8f699c.tar.gz
SorensenCompression-7bd18b4b22f3a6bf86b131329345f9a75d8f699c.zip
Commit Rust POC
This replaces the Python script. Since all MIT-licensed code is removed, the LICENSE file is as well. 'cargo run' to run the program. Signed-off-by: Malfurious <m@lfurio.us>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 12 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..679c3b3
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,12 @@
+[package]
+name = "pszip"
+version = "0.1.0"
+authors = ["malf"]
+edition = "2018"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+sha2 = "0.8.1"
+num = "*"
+hex = "0.3.1"