summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authordusoleil <howcansocksbereal@gmail.com>2021-08-30 05:00:00 -0400
committerdusoleil <howcansocksbereal@gmail.com>2021-08-30 05:00:00 -0400
commite342ae082960cad4d05d719914801f907cd9d61d (patch)
treebd37ce9a0a237b9efcf2025cea996c0d49b197da /setup.py
parentb33db8c57b0875904610ae5dec64a653332ac835 (diff)
downloadsploit-e342ae082960cad4d05d719914801f907cd9d61d.tar.gz
sploit-e342ae082960cad4d05d719914801f907cd9d61d.zip
Sploit Rework MVP Structure, Packaging, and Comms
First part of the MVP for the larger Sploit rework effort. Add project structure, python packaging, basic comms, and "log" hook. From in or out of the sploit directory, you can run the "sploit.py" script, run python -m sploit, or import the sploit modules from the python3 shell. You can also pip install Sploit and from anywhere you can run the sploit command, run python -m sploit, or import the sploit modules from the python3 shell. Running as a standalone application, Sploit can run in a "target" mode, a "pipe" mode, and a "pipe daemon" mode. In "target" mode, Sploit will launch a target program as a subprocess and run an exploit script against its I/O. In "pipe" mode, Sploit will create named fifos and wait for a program to connect to them to run an exploit script against them. In "pipe daemon" mode, Sploit will run similar to the "pipe" mode, but automatically recreate the fifos with the same name after each execution. Basic comm operations of read, readline, write, and writeline are available to the exploit script. A "log" hook is executed whenever data is read in from the target program. This will just print the data out, but it can be configured to decode it with a specific encoding or you could replace the function for different behavior. Signed-off-by: dusoleil <howcansocksbereal@gmail.com>
Diffstat (limited to '')
-rw-r--r--setup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..eb1b299
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,7 @@
+from setuptools import setup
+setup(
+ name='sploit',
+ version='0',
+ packages=['sploit'],
+ entry_points={"console_scripts":["sploit=sploit.main:main"]}
+ )