summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMalfurious <m@lfurio.us>2023-11-29 21:33:25 -0500
committerMalfurious <m@lfurio.us>2023-11-29 21:33:25 -0500
commitf9aeadc2d06ea9a48a2b0cc4cbbb5a80d8bdcca4 (patch)
treed01879807ec459514288fb7d29672224427754a3
parentdbfcf6f4438f4b9bdc7ce5e2ac75091d6f3ba7f8 (diff)
downloadrice-f9aeadc2d06ea9a48a2b0cc4cbbb5a80d8bdcca4.tar.gz
rice-f9aeadc2d06ea9a48a2b0cc4cbbb5a80d8bdcca4.zip
Add wmname submodule
-rw-r--r--.gitmodules4
-rw-r--r--.xinitrc1
-rw-r--r--rice/submodules/Makefile2
m---------rice/submodules/wmname0
4 files changed, 7 insertions, 0 deletions
diff --git a/.gitmodules b/.gitmodules
index 9f70e68..15ad774 100644
--- a/.gitmodules
+++ b/.gitmodules
@@ -22,3 +22,7 @@
path = .vim/pack/plugins/start/vim-polyglot
url = https://github.com/sheerun/vim-polyglot.git
branch = master
+[submodule "rice/submodules/wmname"]
+ path = rice/submodules/wmname
+ url = ../wmname
+ branch = master
diff --git a/.xinitrc b/.xinitrc
index ff849db..d7fe252 100644
--- a/.xinitrc
+++ b/.xinitrc
@@ -9,6 +9,7 @@ while true; do
done &
picom --config /dev/null -bfD3 --xrender-sync-fence
+wmname LG3D
unclutter --fork --start-hidden
xset dpms 0 0 0
xset s off
diff --git a/rice/submodules/Makefile b/rice/submodules/Makefile
index 700c55b..e5b95b9 100644
--- a/rice/submodules/Makefile
+++ b/rice/submodules/Makefile
@@ -5,6 +5,7 @@ all:
$(MAKE) -C dwm
$(MAKE) -C slock
$(MAKE) -C st
+ $(MAKE) -C wmname
install:
$(MAKE) -C dmenu install
@@ -12,3 +13,4 @@ install:
$(MAKE) -C git-sonar install
$(MAKE) -C slock install
$(MAKE) -C st install
+ $(MAKE) -C wmname install
diff --git a/rice/submodules/wmname b/rice/submodules/wmname
new file mode 160000
+Subproject fffffffffffffffffffffffffffffffffffffff